Updates von Home Assistant schlagen erneut fehl

Nachdem sich Home Assistant vor einigen Wochen merkwürdig verhalten hat hatte sich alles wieder etwas beruhigt, aber Mitte Mai lief wieder das Update nicht durch.

Dieses Mal deutete die Suche im Internet darauf hin dass entweder der Platz auf der SD-Karte ausgeht oder diese korrupt wäre. Es wurde empfohlen die letzte Sicherung wieder einzuspielen, diese würde alles wieder korrekt installieren.

Leider tat sie das nicht - oder die SD-Karte ist tatsächlick defekt. Jedenfalls hinterließ die Wiederherstellung des Backups nichts wovon mein Raspberry auch nur halbwegs booten wollte. So viel zum Thema Backup: es nutzt nichts wenn man seine Daten sichert, man muss auch einmal testen ob das Wiederherstellen funktioniert.

Glücklicherweise hatte ich meine Konfigurationsdateien vorher gesichert und musste nur hass.io auf eine neue Karte brennen. Vor dieser startete aber der Test-Raspberry an meinem Schreibtisch nicht. Also versuchte ich zwei bis vier Images - aber nichts passierte. Es dauerte eine ganzer Weile bis ich endlich einmal den Raspberry austauschte - und siehe da, Home Assistant startete ohne Probleme. Offenbar war mein Test-Raspberry defekt.

Der Rest lief dann relativ einfach, nur die letzten Änderungen meines Wohnungsplanes hatte ich noch nicht abgespeichert.

Das Schöne an der Neuinstallation ist dass die Lampen und Sensoren nun vernünftige Namen haben. Ok, es bereitet ein wenig Arbeit die Skripte anzupassen, aber "PIR_45_Esszimmer" ist deutlich besser als "sensor_zwave_pir_2" oder so etwas.

Daraufhin formulierte ich ein

Vorgehen beim Installieren von neuen Geräten

Hue-Entertainment-Bereich:

Tradfri geht nicht!

Wer vorhat einen Entertainment-Bereich (zum Beispiel um die Birnen mittels der Razer-Software anzusteuern) einzurichten: kauft dafür keine Tradfri-Lampen, denn auch wenn ihr diese erfolgreich an der Hue-Bridge anmeldet könnt ihr sie nicht zu einem Entertainment-Bereich anmelden und sie damit nicht mit der Razor-Software steuern!

Bislang habe ich neue Lampen einfach nur bei der jeweiligen Bridge angemeldet und dann umbenannt. Das Problem hierbei ist dass die Bridge dann erst einmal einen allgemeinen Namen vergibt, zum Beispiel Colorlight_1. Anschließend habe ich das dann zu "Ambient Links" umbenannt weil ich die Birne zur Ambiente-Beleuchtung des Schreibtisches einsetzen wollte.

Leider hat zu diesem Zeitpunkt Home Assistant die Birne bereits gesehen und als "Colorlight_1" angelegt. Sie in HA umzubenennen führte dazu dass ich die Birne doppelt im System hatte, später sogar drei Mal nachdem ich sie zu "Licht Bei Küche" umbenannt hatte.

Wer also Lampen anlegt und auf einen sprechenden Namen in Home Assistant Wert legt: schaltet HA vor dem Anlegen komplett aus!

 

Experimente mit Nore-Red

Weil ich dann schon einmal dabei war die Skripte zu überarbeiten machte ich mich daran mal wieder Node-Red anzuschauen. 

Nachdem ich mir ein, zwei Tutorials angesehen hatte funktionierte es schonn ganz gut, allerdings bereiten mir Entscheidungen noch Probleme. So kann ich im Moment einen Warnton anschalten wenn ich den Tiefkühlschrank nicht (richtig) schließe, aber dieser hört nicht auf wenn ich die Tür ordentlich zu mache.