Article Index

Home Assistant OS installieren

Das System läuft nun nicht mehr als Docker-Container sondern als komplettes Betriebssystem in einer virtuellen Maschine. Bei meinem QNAP-NAS muss ich darum die "Virtualization Station" anstelle des Container Managers verwenden.

Zunächst muss das entsprechende Image heruntergeladen werden, und zwar in der VM-Ware-Version. Zum Zeitpunkt des Schreibens ist das diese Version:

https://github.com/home-assistant/operating-system/releases/download/5.13/hassos_ova-5.13.ova

Dann gehe ich in der VirtStation auf Import und wähle diese Datei als Quelle aus. Die anschließenden Einstellungen habe ich an die Fähigkeiten eines Raspberry angepasst, also eine CPU und 1GB Speicher.

QNAP: USB verbinden

Wichtig ist noch einen angemessenen Ort für die "Festplatte" der VM zu definieren, ich habe dazu auf der System-Partition einen Ordner angelegt und meinem Benutzer Schreibrechte darauf gegeben. Die Rechte sind vermutlich unnötig, aber schaden auch nichts. Das Importieren dauert ein wenig, aber danach kann es mit dem regulären Onboarding von Home Assistant weiter gehen. Die Oberfläche der VM zeigt den HassOS-Login. Wer sich einloggen will, der Benutzer ist "root" und hat kein Passwort.

Wer einen ZWave-Stick oder sonstige USB-Geräte verwendet sollte die Maschine anhalten und das entsprechende USB-Gerät verbinden. Dazu dient der fünfte Button. Allerdings hat das bei mir nicht dazu geführt dass die VM des Gerät gesehen hat.

Zunächst hatte ich keinen Zugriff auf das Webinterface denn der Host leitet Anfragen nicht an die VM weiter - sie hat vermutlich eine eigene IP-Adresse. Bisher habe ich noch nicht herausgefunden wie ich diese bestimme. Es scheint über virtuelle Switches zu gehen, aber wie weiß ich noch nicht. Nach etwas Herumprobieren ging plötzlich gar nichts mehr - das NAS war nicht mehr erreichbar.

Was auch immer ich gemacht hatte, ich habe irgendwie das NAS vom Netzwerk getrennt. Ich konnte mich dann zwar mit Monitor und Tastatur direkt anmelden, aber via Shell das System zu reparieren war mir zu blöd. Also habe ich das NAS zurückgesetzt.